]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/dokuwiki.nix
Move ttrss, wallabag, ldap and roundcubemail passwords to secure location
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / dokuwiki.nix
index ad1497f16179291a44145b80d9afdfb388c7adc8..2cd19f10a8698772a18018202ea15ce0f88131e4 100644 (file)
@@ -48,8 +48,8 @@ let
       installPhase = ''
         cp -a . $out
         cp ${preload} $out/inc/preload.php
-        ln -sf ../../../../../${varDir}/{conf,data} $out/
-        ln -sf ../../../../../${varDir}/conf/.htaccess $out/
+        ln -sf ${varDir}/{conf,data} $out/
+        ln -sf ${varDir}/conf/.htaccess $out/
         ${builtins.concatStringsSep "\n" (
           lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/lib/plugins/${name}") plugins
         )}
@@ -76,6 +76,7 @@ let
         '';
     };
     phpFpm = rec {
+      serviceDeps = [ "openldap.service" ];
       basedir = builtins.concatStringsSep ":" (
         [ webRoot varDir ]
         ++ lib.attrsets.mapAttrsToList (name: value: value) plugins);