]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/default.nix
Upgrade nixpkgs for env
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / default.nix
index b1fd8f2fb2f9c313a5249aa90a5b09e791f1c523..aa59e280d6c254c930b9c3ebf54f2b894acdfdf8 100644 (file)
@@ -8,7 +8,10 @@ let
       inherit (mylibs) fetchedGithub fetchedGit;
       env = myconfig.env.tools.ttrss;
     };
-    roundcubemail = pkgs.callPackage ./roundcubemail.nix { env = myconfig.env.tools.roundcubemail; };
+    roundcubemail = pkgs.callPackage ./roundcubemail.nix {
+      inherit (mylibs) fetchedGithub;
+      env = myconfig.env.tools.roundcubemail;
+    };
     rainloop = pkgs.callPackage ./rainloop.nix  {};
     kanboard = pkgs.callPackage ./kanboard.nix  {
       inherit (mylibs) fetchedGithub;
@@ -126,6 +129,7 @@ in {
       ];
     };
 
+    services.myPhpfpm.poolPhpConfigs.roundcubemail = roundcubemail.phpFpm.phpConfig;
     services.myPhpfpm.poolConfigs = {
       adminer = adminer.phpFpm.pool;
       ttrss = ttrss.phpFpm.pool;