]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/default.nix
Add shaarli website
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / default.nix
index 333ffb0c79e9cf6129b34f7340dd1ccf20bb4650..41f47a3f458305c072fac90711dd7b8d197d788d 100644 (file)
@@ -18,6 +18,9 @@ let
       inherit (mylibs) fetchedGithub;
       env = myconfig.env.tools.rompr;
     };
+    shaarli = pkgs.callPackage ./shaarli.nix {
+      env = myconfig.env.tools.shaarli;
+    };
 
     cfg = config.services.myWebsites.tools.tools;
 in {
@@ -35,7 +38,8 @@ in {
       ++ roundcubemail.apache.modules
       ++ wallabag.apache.modules
       ++ yourls.apache.modules
-      ++ rompr.apache.modules;
+      ++ rompr.apache.modules
+      ++ shaarli.apache.modules;
 
     services.ympd = ympd.config // { enable = true; };
 
@@ -51,6 +55,7 @@ in {
         wallabag.apache.vhostConf
         yourls.apache.vhostConf
         rompr.apache.vhostConf
+        shaarli.apache.vhostConf
       ];
     };
 
@@ -61,6 +66,7 @@ in {
       wallabag = wallabag.phpFpm.pool;
       yourls = yourls.phpFpm.pool;
       rompr = rompr.phpFpm.pool;
+      shaarli = shaarli.phpFpm.pool;
     };
 
     system.activationScripts = {
@@ -69,6 +75,7 @@ in {
       wallabag = wallabag.activationScript;
       yourls = yourls.activationScript;
       rompr = rompr.activationScript;
+      shaarli = shaarli.activationScript;
     };
 
     systemd.services.tt-rss = {