]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/default.nix
Add peertube tool
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / default.nix
index 5db7d3eb5a3e7d4127922ae49186a83fdc7fcd26..2060c79156490f7e6ecbc490dbf68bd0e41d94b1 100644 (file)
@@ -59,6 +59,7 @@ in {
       extraConfig = [
         ''
           <Directory "/var/lib/ftp/tools.immae.eu">
+            DirectoryIndex index.php index.htm index.html
             AllowOverride all
             Require all granted
             <FilesMatch "\.php$">
@@ -117,6 +118,10 @@ in {
       dokuwiki = dokuwiki.activationScript;
     };
 
+    nixpkgs.config.packageOverrides = oldpkgs: rec {
+      ympd = oldpkgs.ympd.overrideAttrs(old: mylibs.fetchedGithub ./ympd.json);
+    };
+
     systemd.services.tt-rss = {
       description = "Tiny Tiny RSS feeds update daemon";
       serviceConfig = {