]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/default.nix
Add peertube tool
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / default.nix
index 4bbd5cdc931076e5fb825600afdbf05cb39ddc48..2060c79156490f7e6ecbc490dbf68bd0e41d94b1 100644 (file)
@@ -24,6 +24,9 @@ let
     dokuwiki = pkgs.callPackage ./dokuwiki.nix {
       inherit (mylibs) fetchedGithub;
     };
+    ldap = pkgs.callPackage ./ldap.nix {
+      env = myconfig.env.tools.phpldapadmin;
+    };
 
     cfg = config.services.myWebsites.tools.tools;
 in {
@@ -44,7 +47,8 @@ in {
       ++ yourls.apache.modules
       ++ rompr.apache.modules
       ++ shaarli.apache.modules
-      ++ dokuwiki.apache.modules;
+      ++ dokuwiki.apache.modules
+      ++ ldap.apache.modules;
 
     services.ympd = ympd.config // { enable = true; };
 
@@ -55,6 +59,7 @@ in {
       extraConfig = [
         ''
           <Directory "/var/lib/ftp/tools.immae.eu">
+            DirectoryIndex index.php index.htm index.html
             AllowOverride all
             Require all granted
             <FilesMatch "\.php$">
@@ -71,6 +76,7 @@ in {
         rompr.apache.vhostConf
         shaarli.apache.vhostConf
         dokuwiki.apache.vhostConf
+        ldap.apache.vhostConf
       ];
     };
 
@@ -83,6 +89,7 @@ in {
       rompr = rompr.phpFpm.pool;
       shaarli = shaarli.phpFpm.pool;
       dokuwiki = dokuwiki.phpFpm.pool;
+      ldap = ldap.phpFpm.pool;
       tools = ''
         listen = /var/run/phpfpm/tools.sock
         user = wwwrun
@@ -111,6 +118,10 @@ in {
       dokuwiki = dokuwiki.activationScript;
     };
 
+    nixpkgs.config.packageOverrides = oldpkgs: rec {
+      ympd = oldpkgs.ympd.overrideAttrs(old: mylibs.fetchedGithub ./ympd.json);
+    };
+
     systemd.services.tt-rss = {
       description = "Tiny Tiny RSS feeds update daemon";
       serviceConfig = {