]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mediagoblin.nix
Remove unneeded dependencies in modules
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mediagoblin.nix
index bdb832336f0fca1fbfbbaf15bd70cd116cd5c75f..6b266811d7e70de3a84e571c645d670a6be1a129 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig,  ... }:
 let
   env = myconfig.env.tools.mediagoblin;
   cfg = config.services.myWebsites.tools.mediagoblin;
@@ -9,7 +9,7 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
-    mySecrets.keys = [{
+    secrets.keys = [{
       dest = "webapps/tools-mediagoblin";
       user = "mediagoblin";
       group = "mediagoblin";
@@ -114,8 +114,8 @@ in {
         ProxyPass /theme_static !
         ProxyPass /plugin_static !
         ProxyPassMatch ^/.well-known/acme-challenge !
-        ProxyPass / unix://${mcfg.socketsDir}/mediagoblin.sock|http://mgoblin.immae.eu/
-        ProxyPassReverse / unix://${mcfg.socketsDir}/mediagoblin.sock|http://mgoblin.immae.eu/
+        ProxyPass / unix://${mcfg.sockets.paster}|http://mgoblin.immae.eu/
+        ProxyPassReverse / unix://${mcfg.sockets.paster}|http://mgoblin.immae.eu/
       '' ];
     };
   };