]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mediagoblin/mediagoblin.nix
Upgrade to latest nixpkgs
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mediagoblin / mediagoblin.nix
index cad6225166a32a4859c24bf9e00f911f502f69dc..53796d572bdaa1fd237dd5b92daa2884a82f404a 100644 (file)
@@ -1,4 +1,4 @@
-{ env, makeWrapper, stdenv, writeText, fetchurl, buildBowerComponents, fetchedGit, fetchedGithub, which, python3, pkgs, automake, autoconf, nodejs, nodePackages, git, cacert }:
+{ env, makeWrapper, stdenv, writeText, fetchurl, buildBowerComponents, fetchedGit, fetchedGithub, which, python36, pkgs, automake, autoconf, nodejs, nodePackages, git, cacert }:
 let
   plugins = {
     basicsearch = stdenv.mkDerivation (fetchedGithub ./mediagoblin-plugin-basicsearch.json // rec {
@@ -68,11 +68,11 @@ let
           url = "mirror://pypi/P/PasteScript/${name}.tar.gz";
           sha256 = "1h3nnhn45kf4pbcv669ik4faw04j58k8vbj1hwrc532k0nc28gy0";
         };
-        propagatedBuildInputs = with self; [ six paste PasteDeploy argparse ];
+        propagatedBuildInputs = with self; [ six paste PasteDeploy ];
       });
     };
     in
-      python3.override { inherit packageOverrides; };
+      python36.override { inherit packageOverrides; };
   pythonEnv = python-pkgs: with python-pkgs; [
     waitress alembic dateutil wtforms pybcrypt
     pytest pytest_xdist werkzeug celery
@@ -80,7 +80,7 @@ let
     sqlalchemy itsdangerous pytz sphinx six
     oauthlib unidecode jsonschema PasteDeploy
     requests PyLD exifread
-    typing pasteScript
+    typing pasteScript lxml
     # For images plugin
     pillow
     # For video plugin
@@ -282,7 +282,7 @@ in
           find . -type f -exec sed -i "s|$mediagoblin|$out|g" {} \;
           ln -s ${paste_local} ./paste_local.ini
           ln -s ${mediagoblin_local} ./mediagoblin_local.ini
-          ln -sf ../../../../../${varDir} ./user_dev
+          ln -sf ${varDir} ./user_dev
           '';
       };
   }