]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/mastodon.nix
Remove useless relative symlinks
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
index 8650ee310b860e9e28e5d6780b60b421c69aa771..ef7ef576dfc70367ba6e957b44ffa658277280f5 100644 (file)
@@ -42,7 +42,7 @@ let
             buildInputs = with pkgs; [ nodePackages.node-pre-gyp ];
           };
           node-sass = {
-            buildInputs = with pkgs; [ binutils libsass python ];
+            buildInputs = with pkgs; [ libsass python ];
             postInstall = let
               nodeHeaders = pkgs.fetchurl {
                 url = "https://nodejs.org/download/release/v${pkgs.nodejs.version}/node-v${pkgs.nodejs.version}-headers.tar.gz";
@@ -50,7 +50,6 @@ let
               };
             in
               ''
-                export AR=${pkgs.binutils.bintools}/bin/ar
                 node scripts/build.js --tarball=${nodeHeaders}
               '';
           };
@@ -91,6 +90,8 @@ let
 
     STREAMING_CLUSTER_NUM=1
 
+    RAILS_LOG_LEVEL=warn
+
     # LDAP authentication (optional)
     LDAP_ENABLED=true
     LDAP_HOST=ldap.immae.eu
@@ -118,7 +119,7 @@ let
         sed -i -e 's@^end$@  config.action_mailer.sendmail_settings = { location: ENV.fetch("SENDMAIL_LOCATION", "/usr/sbin/sendmail") }\nend@' config/environments/production.rb
         RAILS_ENV=production ${gems}/bin/rails assets:precompile
         rm -rf tmp/cache
-        ln -sf ../../../../../../../${varDir}/tmp/cache tmp
+        ln -sf ${varDir}/tmp/cache tmp
         '';
       buildInputs = [ gems gems.ruby pkgs.nodejs pkgs.yarn ];
     };