]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/default.nix
Temporarily fix mastodon package
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / default.nix
index b0ace5681988e95f0c17bb47203484a1b33f9c3b..cff62007bf0d8846d9eba2a49e7343fa08dc96fb 100644 (file)
@@ -1,6 +1,6 @@
-{ lib, pkgs, pkgsPrevious, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig, mylibs, ... }:
 let
-  mastodon = pkgsPrevious.callPackage ./mastodon.nix {
+  mastodon = pkgs.callPackage ./mastodon.nix {
     inherit (mylibs) fetchedGithub;
     env = myconfig.env.tools.mastodon;
   };
@@ -71,7 +71,7 @@ in {
       after = [ "network.target" ];
 
       environment.RAILS_ENV = "production";
-      environment.BUNDLE_PATH = "${mastodon.gems}/lib/ruby/gems/2.5.0";
+      environment.BUNDLE_PATH = "${mastodon.gems}/${mastodon.gems.ruby.gemPath}";
       environment.BUNDLE_GEMFILE = "${mastodon.gems.confFiles}/Gemfile";
       environment.SOCKET = mastodon.railsSocket;