]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/default.nix
Temporarily fix mastodon package
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / default.nix
index 6e34280f30f6086951347ce6d5933db4b5abdc03..cff62007bf0d8846d9eba2a49e7343fa08dc96fb 100644 (file)
@@ -21,7 +21,7 @@ in {
       uid = config.ids.uids.mastodon;
       group = "mastodon";
       description = "Mastodon user";
-      home = mastodon.railsRoot;
+      home = mastodon.varDir;
       useDefaultShell = true;
     };
 
@@ -71,7 +71,7 @@ in {
       after = [ "network.target" ];
 
       environment.RAILS_ENV = "production";
-      environment.BUNDLE_PATH = "${mastodon.gems}/lib/ruby/gems/2.5.0";
+      environment.BUNDLE_PATH = "${mastodon.gems}/${mastodon.gems.ruby.gemPath}";
       environment.BUNDLE_GEMFILE = "${mastodon.gems.confFiles}/Gemfile";
       environment.SOCKET = mastodon.railsSocket;