]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/default.nix
Move etherpad mastodon mediagoblin task and peertube to new secrets
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / default.nix
index 048d845c8906b200ae33c1e7d44b6c161bd2509f..a3f2364ee0cdfcbb2e6add96ff889ad09a6f2cff 100644 (file)
@@ -13,7 +13,7 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
-    deployment.keys = mastodon.keys;
+    mySecrets.keys = mastodon.keys;
     ids.uids.mastodon = myconfig.env.tools.mastodon.user.uid;
     ids.gids.mastodon = myconfig.env.tools.mastodon.user.gid;
 
@@ -55,7 +55,7 @@ in {
 
       serviceConfig = {
         User = "mastodon";
-        EnvironmentFile = "/run/keys/webapps/tools-mastodon";
+        EnvironmentFile = "/var/secrets/webapps/tools-mastodon";
         PrivateTmp = true;
         Restart = "always";
         TimeoutSec = 15;
@@ -88,7 +88,7 @@ in {
 
       serviceConfig = {
         User = "mastodon";
-        EnvironmentFile = "/run/keys/webapps/tools-mastodon";
+        EnvironmentFile = "/var/secrets/webapps/tools-mastodon";
         PrivateTmp = true;
         Restart = "always";
         TimeoutSec = 60;
@@ -117,7 +117,7 @@ in {
 
       serviceConfig = {
         User = "mastodon";
-        EnvironmentFile = "/run/keys/webapps/tools-mastodon";
+        EnvironmentFile = "/var/secrets/webapps/tools-mastodon";
         PrivateTmp = true;
         Restart = "always";
         TimeoutSec = 15;