]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/git/mantisbt/mantisbt.nix
Move tools to new secrets location
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / git / mantisbt / mantisbt.nix
index b564058c067db6bab7ed86107090e5d3c508f6e3..41c5e90a5c572848d23fd73615e90980d7536c77 100644 (file)
@@ -17,8 +17,8 @@ let
       });
     };
   in rec {
-    keys."tools-mantisbt" = {
-      destDir = "/run/keys/webapps";
+    keys = [{
+      dest = "webapps/tools-mantisbt";
       user = apache.user;
       group = apache.group;
       permissions = "0400";
@@ -56,7 +56,7 @@ let
         $g_ldap_realname_field = 'cn';
         $g_ldap_organization = '(memberOf=cn=users,cn=mantisbt,ou=services,dc=immae,dc=eu)';
       '';
-    };
+    }];
     webRoot = stdenv.mkDerivation rec {
       name = "mantisbt-${version}";
       version = "2.11.1";
@@ -72,7 +72,7 @@ let
         ];
       installPhase = ''
         cp -a . $out
-        ln -s /run/keys/webapps/tools-mantisbt $out/config/config_inc.php
+        ln -s /var/secrets/webapps/tools-mantisbt $out/config/config_inc.php
         ln -s ${plugins.slack} $out/plugins/Slack
         ln -s ${plugins.source-integration}/Source* $out/plugins/
       '';
@@ -102,9 +102,9 @@ let
         '';
     };
     phpFpm = rec {
-      serviceDeps = [ "postgresql.service" "openldap.service" "tools-mantisbt-key.service" ];
+      serviceDeps = [ "postgresql.service" "openldap.service" ];
       basedir = builtins.concatStringsSep ":" (
-        [ webRoot "/run/keys/webapps/tools-mantisbt" ]
+        [ webRoot "/var/secrets/webapps/tools-mantisbt" ]
         ++ lib.attrsets.mapAttrsToList (name: value: value) plugins);
       socket = "/var/run/phpfpm/mantisbt.sock";
       pool = ''