]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/git/mantisbt/mantisbt.nix
Cleanup e-mails from immae.eu domains
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / git / mantisbt / mantisbt.nix
index c6c3bff60ea5a31c8bb553753046210f6907a8bb..0cd98a1901f4afa2522d6a1295782f45a79403b5 100644 (file)
@@ -30,14 +30,14 @@ let
       $g_allow_anonymous_login = ON;
       $g_anonymous_account     = 'anonymous';
 
-      $g_phpMailer_method      = PHPMAILER_METHOD_SMTP;
-      $g_smtp_host             = 'mail.immae.eu';
+      $g_phpMailer_method      = PHPMAILER_METHOD_SENDMAIL;
+      $g_smtp_host             = 'localhost';
       $g_smtp_username         = ''';
       $g_smtp_password         = ''';
-      $g_webmaster_email       = 'webmaster@immae.eu';
-      $g_from_email            = 'noreply@immae.eu';
-      $g_return_path_email     = 'webmaster@immae.eu';
-      $g_from_name             = 'Mantis Bug Tracker at immae.eu';
+      $g_webmaster_email       = 'mantisbt@tools.immae.eu';
+      $g_from_email            = 'mantisbt@tools.immae.eu';
+      $g_return_path_email     = 'mantisbt@tools.immae.eu';
+      $g_from_name             = 'Mantis Bug Tracker at git.immae.eu';
       $g_email_receive_own     = OFF;
       # --- LDAP ---
       $g_login_method = LDAP;
@@ -72,13 +72,15 @@ let
         ln -s ${plugins.source-integration}/Source* $out/plugins/
       '';
     };
-    apache = {
+    apache = rec {
       user = "wwwrun";
       group = "wwwrun";
       modules = [ "proxy_fcgi" ];
+      webappName = "tools_mantisbt";
+      root = "/run/current-system/webapps/${webappName}";
       vhostConf = ''
-        Alias /mantisbt "${webRoot}"
-        <Directory "${webRoot}">
+        Alias /mantisbt "${root}"
+        <Directory "${root}">
           DirectoryIndex index.php
           <FilesMatch "\.php$">
             SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
@@ -88,7 +90,7 @@ let
           Options FollowSymlinks
           Require all granted
         </Directory>
-        <Directory "${webRoot}/admin">
+        <Directory "${root}/admin">
           #Reenable during upgrade
           Require all denied
         </Directory>