]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/ftp/temp.nix
Add certificate creation and handling to websites
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ftp / temp.nix
index 10331217b9a828f4ee2d9b034b7de132bc925256..86dfde35fab7c923db6ce06fb8b49463302e9a12 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig,  ... }:
 let
     cfg = config.services.myWebsites.Temp;
     varDir = "/var/lib/ftp/temp.immae.eu";
@@ -11,16 +11,15 @@ in {
   };
 
   config = lib.mkIf cfg.production.enable {
-    security.acme.certs."eldiron".extraDomains."temp.immae.eu" = null;
-
-    services.myWebsites.production.modules = [ "headers" ];
-    services.myWebsites.production.vhostConfs.temp = {
+    services.websites.production.modules = [ "headers" ];
+    services.websites.production.vhostConfs.temp = {
       certName    = "eldiron";
+      addToCerts  = true;
       hosts       = [ "temp.immae.eu" ];
       root        = varDir;
       extraConfig = [
         ''
-        Use Apaxy "${varDir}" "title"
+        Use Apaxy "${varDir}" "title .duplicity-ignore"
         <FilesMatch ".+">
           Header set Content-Disposition attachment
         </FilesMatch>