]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/ftp/temp.nix
Remove direct dependency to myconfig in database modules
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ftp / temp.nix
index 7f9f68160a6ca036378f5280ea2bf2ce7c4b20c8..86dfde35fab7c923db6ce06fb8b49463302e9a12 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig,  ... }:
 let
     cfg = config.services.myWebsites.Temp;
     varDir = "/var/lib/ftp/temp.immae.eu";
@@ -11,11 +11,10 @@ in {
   };
 
   config = lib.mkIf cfg.production.enable {
-    security.acme.certs."eldiron".extraDomains."temp.immae.eu" = null;
-
-    services.myWebsites.production.modules = [ "headers" ];
-    services.myWebsites.production.vhostConfs.temp = {
+    services.websites.production.modules = [ "headers" ];
+    services.websites.production.vhostConfs.temp = {
       certName    = "eldiron";
+      addToCerts  = true;
       hosts       = [ "temp.immae.eu" ];
       root        = varDir;
       extraConfig = [