]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/ftp/immae.nix
Remove direct dependency to myconfig in database modules
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ftp / immae.nix
index 64f8f3124e2c4210b8e94135d29f91a2f644f887..2ba30a138f836de220a9c14d4ad715baf32e7e5f 100644 (file)
@@ -13,8 +13,6 @@ in {
   config = lib.mkIf cfg.production.enable {
     services.webstats.sites = [ { name = "www.immae.eu"; } ];
 
-    security.acme.certs."eldiron".extraDomains."www.immae.eu" = null;
-
     services.myPhpfpm.poolConfigs.immae = ''
       listen = /run/phpfpm/immae.sock
       user = wwwrun
@@ -28,9 +26,10 @@ in {
 
       php_admin_value[open_basedir] = "${varDir}:/tmp"
       '';
-    services.myWebsites.production.modules = [ "proxy_fcgi" ];
-    services.myWebsites.production.vhostConfs.immae = {
+    services.websites.production.modules = [ "proxy_fcgi" ];
+    services.websites.production.vhostConfs.immae = {
       certName    = "eldiron";
+      addToCerts  = true;
       hosts       = [ "www.immae.eu" ];
       root        = varDir;
       extraConfig = [
@@ -56,10 +55,9 @@ in {
       ];
     };
 
-    security.acme.certs."eldiron".extraDomains."bouya.org" = null;
-    security.acme.certs."eldiron".extraDomains."www.bouya.org" = null;
-    services.myWebsites.production.vhostConfs.bouya = {
+    services.websites.production.vhostConfs.bouya = {
       certName    = "eldiron";
+      addToCerts  = true;
       hosts       = [ "bouya.org" "www.bouya.org" ];
       root        = null;
       extraConfig = [ ''