]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/ftp/florian.nix
Move personal websites to modules
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ftp / florian.nix
diff --git a/nixops/modules/websites/ftp/florian.nix b/nixops/modules/websites/ftp/florian.nix
deleted file mode 100644 (file)
index ebd461e..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-{ lib, pkgs, config, myconfig,  ... }:
-let
-    adminer = pkgs.callPackage ../commons/adminer.nix {};
-    cfg = config.services.myWebsites.Florian;
-    varDir = "/var/lib/ftp/florian";
-    env = myconfig.env.websites.florian;
-in {
-  options.services.myWebsites.Florian = {
-    production = {
-      enable = lib.mkEnableOption "enable Florian's website production";
-    };
-    integration = {
-      enable = lib.mkEnableOption "enable Florian's website integration";
-    };
-  };
-
-  config = lib.mkMerge [
-    (lib.mkIf cfg.production.enable {
-      security.acme.certs."ftp".extraDomains."tellesflorian.com" = null;
-
-      services.websites.production.modules = adminer.apache.modules;
-      services.websites.production.vhostConfs.florian = {
-        certName     = "florian";
-        certMainHost = "tellesflorian.com";
-        hosts        = [ "tellesflorian.com" "www.tellesflorian.com" ];
-        root         = "${varDir}/tellesflorian.com";
-        extraConfig  = [
-          adminer.apache.vhostConf
-          ''
-          ServerAdmin ${env.server_admin}
-
-          <Directory ${varDir}/tellesflorian.com>
-            DirectoryIndex index.php index.htm index.html
-            Options Indexes FollowSymLinks MultiViews Includes
-            AllowOverride None
-            Require all granted
-          </Directory>
-            ''
-        ];
-      };
-    })
-
-    (lib.mkIf cfg.integration.enable {
-      security.acme.certs."ftp".extraDomains."florian.immae.eu" = null;
-
-      services.websites.integration.modules = adminer.apache.modules;
-      services.websites.integration.vhostConfs.florian = {
-        certName    = "eldiron";
-        addToCerts  = true;
-        hosts       = [ "florian.immae.eu" ];
-        root        = "${varDir}/florian.immae.eu";
-        extraConfig = [
-          adminer.apache.vhostConf
-          ''
-          ServerAdmin ${env.server_admin}
-
-          <Directory ${varDir}/florian.immae.eu>
-            DirectoryIndex index.php index.htm index.html
-            Options Indexes FollowSymLinks MultiViews Includes
-            AllowOverride None
-            Require all granted
-          </Directory>
-            ''
-        ];
-      };
-    })
-  ];
-}