]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/chloe/default.nix
Move webstats outside of nixops
[perso/Immae/Config/Nix.git] / nixops / modules / websites / chloe / default.nix
index 451a248e8ddccf267d51e928fe5cbb7ecea3f2b5..a542d70f8e15d5585b5edaf40191527f74857d8b 100644 (file)
@@ -19,20 +19,10 @@ in {
     };
   };
 
-  imports = [
-    ../commons/stats.nix
-  ];
-
   config = lib.mkMerge [
     (lib.mkIf cfg.production.enable {
-      deployment.keys = chloe_prod.keys;
-      services.myWebsites.commons.stats.enable = true;
-      services.myWebsites.commons.stats.sites = [
-        {
-          name = "osteopathe-cc.fr";
-          conf = ./goaccess.conf;
-        }
-      ];
+      secrets.keys = chloe_prod.keys;
+      services.webstats.sites = [ { name = "osteopathe-cc.fr"; } ];
 
       security.acme.certs."chloe" = config.services.myCertificates.certConfig // {
         domain = "osteopathe-cc.fr";
@@ -60,7 +50,7 @@ in {
       };
     })
     (lib.mkIf cfg.integration.enable {
-      deployment.keys = chloe_dev.keys;
+      secrets.keys = chloe_dev.keys;
       security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null;
       services.myPhpfpm.serviceDependencies.chloe_dev = chloe_dev.phpFpm.serviceDeps;
       services.myPhpfpm.poolConfigs.chloe_dev = chloe_dev.phpFpm.pool;