]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/mpd.nix
Use acme directory config rather than hardcoding the value
[perso/Immae/Config/Nix.git] / nixops / modules / mpd.nix
index 7c896ca92ed2eacfcb6160e33cd87617aa06b978..9903bdf0d2ba1dea3701057c740f75a7644610a3 100644 (file)
@@ -1,7 +1,7 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig,  ... }:
 {
   config = {
-    mySecrets.keys = [
+    secrets.keys = [
       {
         dest = "mpd";
         permissions = "0400";
@@ -19,9 +19,7 @@
     ];
     networking.firewall.allowedTCPPorts = [ 6600 ];
     users.users.mpd.extraGroups = [ "wwwrun" "keys" ];
-    system.activationScripts.mpd = ''
-      install -d -m 0755 -o mpd -g mpd /run/mpd
-      '';
+    systemd.services.mpd.serviceConfig.RuntimeDirectory = "mpd";
     services.mpd = {
       enable = true;
       network.listenAddress = "any";