]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/mpd/default.nix
Move ympd password to secure location
[perso/Immae/Config/Nix.git] / nixops / modules / mpd / default.nix
index 7781b363dba7bbbaaff1b38297047e602c32537a..d59a34cd0b5048858e6e025d1b2ffcbcca6b47b8 100644 (file)
@@ -1,6 +1,12 @@
 { lib, pkgs, config, myconfig, mylibs, ... }:
 {
   config = {
+    deployment.keys = {
+      mpd = {
+        permissions = "0400";
+        text = myconfig.env.mpd.password;
+      };
+    };
     networking.firewall.allowedTCPPorts = [ 6600 ];
     users.users.mpd.extraGroups = [ "wwwrun" ];
     services.mpd = {