]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/databases/postgresql.nix
Upgrade mysql and postgresql
[perso/Immae/Config/Nix.git] / nixops / modules / databases / postgresql.nix
index f839d6338a10eadd73df4c3c921e13de5e111b8a..7046b4566c2b37dcfd4c6c5fe1e63b7d13f7ccab 100644 (file)
@@ -1,5 +1,6 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, pkgsNext, config, myconfig, mylibs, ... }:
 let
+    pkgs = pkgsNext.appendOverlays config.nixpkgs.overlays;
     cfg = config.services.myDatabases;
 in {
   options.services.myDatabases = {
@@ -15,20 +16,29 @@ in {
 
   config = lib.mkIf cfg.enable {
     nixpkgs.overlays = [ (self: super: rec {
-      postgresql = postgresql111;
-      postgresql111 = super.postgresql100.overrideAttrs(old: rec {
-        passthru = old.passthru // { psqlSchema = "11.0"; };
-        name = "postgresql-11.1";
-        src = self.fetchurl {
-          url = "mirror://postgresql/source/v11.1/${name}.tar.bz2";
-          sha256 = "026v0sicsh7avzi45waf8shcbhivyxmi7qgn9fd1x0vl520mx0ch";
-        };
-        configureFlags = old.configureFlags ++ [ "--with-pam" ];
-        buildInputs = (old.buildInputs or []) ++ [ self.pam ];
-        patches = old.patches ++ [
-          ./postgresql_run_socket_path.patch
-        ];
-      });
+      postgresql = postgresql_11;
+      postgresql_11 = if builtins.hasAttr "postgresql_11" super
+        then super.postgresql_11.overrideAttrs(old: rec {
+          passthru = old.passthru // { psqlSchema = "11.0"; };
+          configureFlags = old.configureFlags ++ [ "--with-pam" ];
+          buildInputs = (old.buildInputs or []) ++ [ self.pam ];
+          patches = old.patches ++ [
+            ./postgresql_run_socket_path.patch
+          ];
+        })
+        else super.postgresql100.overrideAttrs(old: rec {
+          passthru = old.passthru // { psqlSchema = "11.0"; };
+          name = "postgresql-11.1";
+          src = self.fetchurl {
+            url = "mirror://postgresql/source/v11.1/${name}.tar.bz2";
+            sha256 = "026v0sicsh7avzi45waf8shcbhivyxmi7qgn9fd1x0vl520mx0ch";
+          };
+          configureFlags = old.configureFlags ++ [ "--with-pam" ];
+          buildInputs = (old.buildInputs or []) ++ [ self.pam ];
+          patches = old.patches ++ [
+            ./postgresql_run_socket_path.patch
+          ];
+        });
     }) ];
 
     networking.firewall.allowedTCPPorts = [ 5432 ];