]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/databases/postgresql.nix
Upgrade to latest nixpkgs
[perso/Immae/Config/Nix.git] / nixops / modules / databases / postgresql.nix
index 7046b4566c2b37dcfd4c6c5fe1e63b7d13f7ccab..673ced872b23d0dc2a51248d1e613ac06f2dc2cf 100644 (file)
@@ -1,6 +1,5 @@
-{ lib, pkgs, pkgsNext, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig, mylibs, ... }:
 let
-    pkgs = pkgsNext.appendOverlays config.nixpkgs.overlays;
     cfg = config.services.myDatabases;
 in {
   options.services.myDatabases = {
@@ -17,28 +16,14 @@ in {
   config = lib.mkIf cfg.enable {
     nixpkgs.overlays = [ (self: super: rec {
       postgresql = postgresql_11;
-      postgresql_11 = if builtins.hasAttr "postgresql_11" super
-        then super.postgresql_11.overrideAttrs(old: rec {
-          passthru = old.passthru // { psqlSchema = "11.0"; };
-          configureFlags = old.configureFlags ++ [ "--with-pam" ];
-          buildInputs = (old.buildInputs or []) ++ [ self.pam ];
-          patches = old.patches ++ [
-            ./postgresql_run_socket_path.patch
-          ];
-        })
-        else super.postgresql100.overrideAttrs(old: rec {
-          passthru = old.passthru // { psqlSchema = "11.0"; };
-          name = "postgresql-11.1";
-          src = self.fetchurl {
-            url = "mirror://postgresql/source/v11.1/${name}.tar.bz2";
-            sha256 = "026v0sicsh7avzi45waf8shcbhivyxmi7qgn9fd1x0vl520mx0ch";
-          };
-          configureFlags = old.configureFlags ++ [ "--with-pam" ];
-          buildInputs = (old.buildInputs or []) ++ [ self.pam ];
-          patches = old.patches ++ [
-            ./postgresql_run_socket_path.patch
-          ];
-        });
+      postgresql_11 = super.postgresql_11.overrideAttrs(old: rec {
+        passthru = old.passthru // { psqlSchema = "11.0"; };
+        configureFlags = old.configureFlags ++ [ "--with-pam" ];
+        buildInputs = (old.buildInputs or []) ++ [ self.pam ];
+        patches = old.patches ++ [
+          ./postgresql_run_socket_path.patch
+        ];
+      });
     }) ];
 
     networking.firewall.allowedTCPPorts = [ 5432 ];