]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/eldiron.nix
Add some small patches to unclutter the home directory
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
index a4b3f73bd647a0171f65bb7bcb68300d33b6935e..5f0b5d5533ed3718218ff62bec9408c3ba1fd492 100644 (file)
@@ -1,4 +1,4 @@
-{ environment ? ./environment.nix }:
+{ privateFiles ? ./. }:
 {
   network = {
     description = "Immae's network";
   {
     _module.args = {
       mylibs = import ../libs.nix;
+      mypkgs = import ../default.nix;
       myconfig = {
-        env = import environment;
+        inherit privateFiles;
+        env = import "${privateFiles}/environment.nix";
         ips = {
           main = "176.9.151.89";
           production = "176.9.151.154";
@@ -28,6 +30,7 @@
       ./modules/websites
       ./modules/mail
       ./modules/ftp
+      ./modules/pub
     ];
     services.myGitolite.enable = true;
     services.myDatabases.enable = true;
     services.myWebsites.integration.enable = true;
     services.myWebsites.tools.enable = true;
     services.pure-ftpd.enable = true;
+    services.pub.enable = true;
 
+    services.journald.extraConfig = ''
+      MaxLevelStore="warning"
+      MaxRetentionSec="1year"
+      '';
     networking = {
       firewall = {
         enable = true;
         ''
       ];
     };
+
+    # This value determines the NixOS release with which your system is
+    # to be compatible, in order to avoid breaking some software such as
+    # database servers. You should change this only after NixOS release
+    # notes say you should.
+    system.stateVersion = "18.09"; # Did you read the comment?
   };
 }