]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/eldiron.nix
Add ldap
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
index 2376e542c95d39fbab8b830d70803fd9b037c4ca..5dff7d4674203b58c7af6f5be83e8aea93b23f77 100644 (file)
@@ -1,4 +1,4 @@
-{ environment ? ./environment.nix }:
+{ privateFiles ? ./. }:
 {
   network = {
     description = "Immae's network";
   {
     _module.args = {
       mylibs = import ../libs.nix;
+      mypkgs = import ../default.nix;
       myconfig = {
-        env = import environment;
+        inherit privateFiles;
+        env = import "${privateFiles}/environment.nix";
         ips = {
           main = "176.9.151.89";
           production = "176.9.151.154";
         ''
       ];
     };
+
+    # This value determines the NixOS release with which your system is
+    # to be compatible, in order to avoid breaking some software such as
+    # database servers. You should change this only after NixOS release
+    # notes say you should.
+    system.stateVersion = "18.09"; # Did you read the comment?
   };
 }