]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/webapps/webstats/default.nix
Remove mylibs from module dependencies
[perso/Immae/Config/Nix.git] / modules / webapps / webstats / default.nix
index feff951c9eeb324b81044b0bc094e5982d7f3e82..924d72debdf591af8a5fd4e3fa672fccffa6cca5 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, mylibs, ... }:
+{ lib, pkgs, config, ... }:
 let
   name = "goaccess";
   cfg = config.services.webstats;
@@ -59,8 +59,8 @@ in {
             trap "rm -f $TMPFILE" EXIT
 
             mkdir -p ${cfg.dataDir}/${domain}
-            cat /var/log/httpd/access_log-${domain} | sed -n "/\\[$date_regex/ p" > $TMPFILE
-            for i in /var/log/httpd/access_log-${domain}*.gz; do
+            cat /var/log/httpd/access-${domain}.log | sed -n "/\\[$date_regex/ p" > $TMPFILE
+            for i in /var/log/httpd/access-${domain}*.gz; do
               zcat "$i" | sed -n "/\\[$date_regex/ p" >> $TMPFILE
             done
             ${pkgs.goaccess}/bin/goaccess $TMPFILE --no-progress -o ${cfg.dataDir}/${domain}/index.html -p ${config}