]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/webhooks.nix
Move notification systems to apprise
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / webhooks.nix
index c24c09c63b0938916efcafaa2ec6ec58a4e4c0e0..d21e73376a08a47faafa3060bdfcf8aec0edb4ad 100644 (file)
@@ -1,17 +1,17 @@
-{ lib, env }:
+{ lib, env, binEnv }:
 {
   keys = lib.attrsets.mapAttrs' (k: v:
     lib.nameValuePair "webapps/webhooks/${k}.php" {
     user = "wwwrun";
     group = "wwwrun";
     permissions = "0400";
-    text = v;
+    text = builtins.replaceStrings ["{{webhooks-bin-env}}"] [ "${binEnv}" ] v;
   }) env // lib.attrsets.mapAttrs' (k: v:
     lib.nameValuePair "webapps/webhooks/${k}/index.php" {
     user = "wwwrun";
     group = "wwwrun";
     permissions = "0400";
-    text = v;
+    text = builtins.replaceStrings ["{{webhooks-bin-env}}"] [ "${binEnv}" ] v;
   }) env // {
     "webapps/webhooks" = {
       isDir = true;