]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/wallabag.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / wallabag.nix
index ceb061f96c7fcb112b3328bd6bb48d5c69b85419..8ec7c29219927091d08a23df34eb80879716f7bb 100644 (file)
@@ -1,9 +1,5 @@
 { env, wallabag, mylibs, config }:
 rec {
-  backups = {
-    rootDir = varDir;
-    remotes = [ "eriomem" "ovh" ];
-  };
   varDir = "/var/lib/wallabag";
   keys."webapps/tools-wallabag" = {
     user = apache.user;
@@ -68,6 +64,29 @@ rec {
               arguments: ['/run/wrappers/bin/sendmail -bs']
       '';
   };
+  chatonsProperties = {
+    file.datetime = "2022-08-21T22:50:00";
+    service = {
+      name = "Wallabag";
+      description = "wallabag is a self hostable application for saving web pages: Save and classify articles. Read them later. Freely.";
+      website = "https://tools.immae.eu/wallabag/";
+      logo = "https://tools.immae.eu/wallabag/wallassets/themes/_global/img/appicon/apple-touch-icon-120.png";
+      status.level = "OK";
+      status.description = "OK";
+      registration."" = ["MEMBER" "CLIENT"];
+      registration.load = "OPEN";
+      install.type = "PACKAGE";
+    };
+    software = {
+      name = "Wallabag";
+      website = "https://wallabag.org/en";
+      license.url = "https://github.com/wallabag/wallabag/blob/master/COPYING.md";
+      license.name = "MIT License";
+      version = webappDir.version;
+      source.url = "https://github.com/wallabag/wallabag";
+      modules = "ldap-patch";
+    };
+  };
   webappDir = wallabag.override { ldap = true; wallabag_config = config.secrets.fullPaths."webapps/tools-wallabag"; };
   activationScript = ''
     install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir} \