]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/dokuwiki.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / dokuwiki.nix
index aee495ac3fb3af170cc12d9bd5acf4d79be19452..724168e1418b656a2b753aa00d5c21b3c6536399 100644 (file)
@@ -16,6 +16,43 @@ rec {
       install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
     '';
   };
+  chatonsHostingProperties = {
+    file.datetime = "2022-08-21T22:50:00";
+    hosting = {
+      name = "Dokuwiki";
+      description = "DokuWiki is a simple to use and highly versatile Open Source wiki software";
+      website = "https://tools.immae.eu/dokuwiki/";
+      logo = "https://tools.immae.eu/dokuwiki/lib/tpl/dokuwiki/images/apple-touch-icon.png";
+      type = "INSTANCE";
+      status.level = "OK";
+      status.description = "OK";
+      registration.load = "OPEN";
+      install.type = "PACKAGE";
+    };
+  };
+  chatonsProperties = {
+    file.datetime = "2022-08-21T22:50:00";
+    service = {
+      name = "Dokuwiki";
+      description = "DokuWiki is a simple to use and highly versatile Open Source wiki software";
+      website = "https://tools.immae.eu/dokuwiki/";
+      logo = "https://tools.immae.eu/dokuwiki/lib/tpl/dokuwiki/images/apple-touch-icon.png";
+      status.level = "OK";
+      status.description = "OK";
+      registration."" = ["MEMBER" "CLIENT"];
+      registration.load = "OPEN";
+      install.type = "PACKAGE";
+    };
+    software = {
+      name = "Dokuwiki";
+      website = "https://www.dokuwiki.org/dokuwiki";
+      license.url = "http://www.gnu.org/licenses/gpl-2.0.html";
+      license.name = "GNU General Public License Version 2";
+      version = webRoot.version;
+      source.url = "https://download.dokuwiki.org/";
+      modules = map (a: a.pluginName) webRoot.plugins;
+    };
+  };
   webRoot = dokuwiki.withPlugins (p: [ p.farmer p.todo ]);
   apache = rec {
     user = "wwwrun";