]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/default.nix
Move notification systems to apprise
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / default.nix
index 6ca4c177a9fd0451fb03522e0c3a210fee0041cf..e640eb690d8ef241def1293b35b94c921567caf6 100644 (file)
@@ -55,8 +55,14 @@ let
       e.empteintesduweb.monitoranswers e.lr94.autosubscribe
       e.phpbbmodders.adduser ]);
   };
+  webhooks-bin-env = pkgs.buildEnv {
+    name = "webhook-env";
+    paths = [ pkgs.apprise ];
+    pathsToLink = [ "/bin" ];
+  };
   webhooks = pkgs.callPackage ./webhooks.nix {
     env = config.myEnv.tools.webhooks;
+    binEnv = webhooks-bin-env;
   };
   dmarc-reports = pkgs.callPackage ./dmarc_reports.nix {
     env = config.myEnv.tools.dmarc_reports;
@@ -305,6 +311,7 @@ in {
           "php_admin_value[open_basedir]" = builtins.concatStringsSep ":" [
             "/run/wrappers/bin/sendmail" landing "/tmp"
             config.secrets.fullPaths."webapps/webhooks"
+            "${webhooks-bin-env}/bin"
           ];
         };
         phpEnv = {