]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/default.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / default.nix
index e640eb690d8ef241def1293b35b94c921567caf6..133ab9f766e1fa89b31181670e6990ce3e2a1dc4 100644 (file)
@@ -82,6 +82,39 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
+    myServices.chatonsProperties.services = {
+      dokuwiki = dokuwiki.chatonsProperties;
+      shaarli = shaarli.chatonsProperties;
+      ttrss = ttrss.chatonsProperties;
+      wallabag = wallabag.chatonsProperties;
+      paste = {
+        file.datetime = "2022-08-22T00:15:00";
+        service = {
+          name = "Paste";
+          description = "A simple paster script with syntax highlight";
+          website = "https://tools.immae.eu/paste/";
+          logo = "https://assets.immae.eu/logo.jpg";
+          status.level = "OK";
+          status.description = "OK";
+          registration."" = ["MEMBER" "CLIENT"];
+          registration.load = "OPEN";
+          install.type = "PACKAGE";
+          guide.user = "https://tools.immae.eu/paste/";
+        };
+        software = {
+          name = "Paste";
+          website = "https://tools.immae.eu/paste/";
+          license.url = "https://tools.immae.eu/paste/license";
+          license.name = "MIT License";
+          version = "Unversioned";
+          source.url = "https://tools.immae.eu/paste/abcd123/py";
+        };
+      };
+    };
+    myServices.chatonsProperties.hostings = {
+      dokuwiki = dokuwiki.chatonsHostingProperties;
+      phpbb = phpbb.chatonsHostingProperties;
+    };
     secrets.keys =
       kanboard.keys
       // ldap.keys