]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/mail/default.nix
Use pools instead of deprecated poolConfigs for php
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / mail / default.nix
index 218c3a56d3290321700f929b1ef444794e5bad05..bb3604231e399d5f321ee41936e2c3808eee4e7f 100644 (file)
@@ -1,8 +1,8 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   roundcubemail = pkgs.callPackage ./roundcubemail.nix {
     inherit (pkgs.webapps) roundcubemail roundcubemail-plugins roundcubemail-skins;
-    env = myconfig.env.tools.roundcubemail;
+    env = config.myEnv.tools.roundcubemail;
   };
   rainloop = pkgs.callPackage ./rainloop.nix {};
   cfg = config.myServices.websites.tools.email;
@@ -60,8 +60,9 @@ in
       extraConfig = roundcubemail.phpFpm.pool;
       phpOptions = config.services.phpfpm.phpOptions + roundcubemail.phpFpm.phpConfig;
     };
-    services.phpfpm.poolConfigs = {
-      rainloop = rainloop.phpFpm.pool;
+    services.phpfpm.pools.rainloop = {
+      listen = rainloop.phpFpm.socket;
+      extraConfig = rainloop.phpFpm.pool;
     };
     system.activationScripts = {
       roundcubemail = roundcubemail.activationScript;