]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/mail/default.nix
Use new withPlugin system
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / mail / default.nix
index 217ef1ab415e8de84c7a7e0a54c1836af51df5ef..7c60ae45b110c9a0a2538ee7ffdcb7ac972b5460 100644 (file)
@@ -1,7 +1,7 @@
 { lib, pkgs, config,  ... }:
 let
   roundcubemail = pkgs.callPackage ./roundcubemail.nix {
-    inherit (pkgs.webapps) roundcubemail roundcubemail-plugins roundcubemail-skins;
+    inherit (pkgs.webapps) roundcubemail;
     env = config.myEnv.tools.roundcubemail;
   };
   rainloop = pkgs.callPackage ./rainloop.nix {
@@ -64,9 +64,8 @@ in
       settings = roundcubemail.phpFpm.pool;
       phpOptions = config.services.phpfpm.phpOptions + ''
         date.timezone = 'CET'
-        extension=${pkgs.php72Packages.imagick}/lib/php/extensions/imagick.so
       '';
-      phpPackage = pkgs.php72;
+      phpPackage = pkgs.php72.withExtensions(e: pkgs.php72.enabledExtensions ++ [ e.imagick ]);
     };
     services.phpfpm.pools.rainloop = {
       user = "wwwrun";