]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/im/default.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / im / default.nix
index 94dc4f81d242143e8e3561897d67ba21757dc951..372fa323e465ffa3a2529f858888eb4f96335cad 100644 (file)
@@ -8,6 +8,73 @@ in
   };
 
   config = lib.mkIf cfg.enable {
+    myServices.chatonsProperties.services.converse = {
+      file.datetime = "2022-08-21T19:20:00";
+      service = {
+        name = "Converse";
+        description = "A free and open-source XMPP chat client in your browser";
+        website = "https://im.immae.fr/converse";
+        logo = "https://conversejs.org/docs/html/_static/favicon.ico";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["NONE" "FREE"];
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "Converse";
+        website = "https://conversejs.org/";
+        license.name = "Mozilla Public License 2.0";
+        license.url = "https://github.com/conversejs/converse.js/blob/master/LICENSE";
+        version = "9.1.1";
+        source.url = "https://github.com/conversejs/converse.js";
+      };
+    };
+    myServices.chatonsProperties.services.weechat-bridge = {
+      file.datetime = "2022-08-21T19:20:00";
+      service = {
+        name = "Weechat bridge";
+        description = "WeeChat web frontend";
+        website = "https://im.immae.fr/glowing-bear";
+        logo = "https://im.immae.fr/glowing-bear/assets/img/glowing_bear_128x128.png";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["NONE" "FREE"];
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "Glowing bear";
+        website = "https://www.ejabberd.im/";
+        license.name = "GNU General Public License v3.0";
+        license.url = "https://github.com/processone/ejabberd";
+        version = pkgs.glowing-bear.version;
+        source.url = "https://github.com/glowing-bear/glowing-bear";
+      };
+    };
+    myServices.chatonsProperties.services.xmpp = {
+      file.datetime = "2022-08-21T19:20:00";
+      service = {
+        name = "XMPP";
+        description = "Universal messaging standard";
+        website = "https://im.immae.fr/";
+        logo = "https://xmpp.org/favicon-32x32.png";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["MEMBER" "CLIENT"];
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "ejabberd";
+        website = "https://www.ejabberd.im/";
+        license.url = "https://github.com/processone/ejabberd/blob/master/COPYING";
+        license.name = "GNU GENERAL PUBLIC LICENSE Version 2";
+        version = pkgs.ejabberd.version;
+        source.url = "https://github.com/processone/ejabberd";
+        modules = "converse";
+      };
+    };
     services.websites.env.tools.vhostConfs.im = {
       certName   = "eldiron";
       addToCerts = true;