]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/git/default.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / git / default.nix
index a5f525bdad765308c97f6efc7f3e6fe637c8db37..55f9ecb2b0f07a9e67297eb62aa830743d141142 100644 (file)
@@ -19,8 +19,8 @@ in {
     services.websites.env.tools.modules =
       gitweb.apache.modules ++
       mantisbt.apache.modules;
-    myServices.websites.webappDirs."${gitweb.apache.webappName}" = gitweb.webRoot;
-    myServices.websites.webappDirs."${mantisbt.apache.webappName}" = mantisbt.webRoot;
+    services.websites.webappDirs."${gitweb.apache.webappName}" = gitweb.webRoot;
+    services.websites.webappDirs."${mantisbt.apache.webappName}" = mantisbt.webRoot;
 
     system.activationScripts.mantisbt = mantisbt.activationScript;
     services.websites.env.tools.vhostConfs.git = {
@@ -30,7 +30,7 @@ in {
       root        = gitweb.apache.root;
       extraConfig = [
         gitweb.apache.vhostConf
-        mantisbt.apache.vhostConf
+        (mantisbt.apache.vhostConf config.services.phpfpm.pools.mantisbt.socket)
         ''
           RewriteEngine on
           RewriteCond %{REQUEST_URI}       ^/releases
@@ -38,8 +38,12 @@ in {
           ''
       ];
     };
-    services.phpfpm.poolConfigs = {
-      mantisbt = mantisbt.phpFpm.pool;
+    services.phpfpm.pools = {
+      mantisbt = {
+        user = config.services.httpd.Tools.user;
+        group = config.services.httpd.Tools.group;
+        settings = mantisbt.phpFpm.pool;
+      };
     };
   };
 }