]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/dav/default.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / dav / default.nix
index b3aa03deb7336c697c028b5bfdfcab704286826a..289a56979304a520554be31bf06a0fc491e56450 100644 (file)
@@ -27,6 +27,75 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
+    myServices.chatonsProperties.services = {
+      davical = {
+        file.datetime = "2022-08-21T01:33:00";
+        service = {
+          name = "Davical";
+          description = "DAViCal is a server for calendar sharing";
+          website = "https://dav.immae.eu";
+          logo = "https://www.davical.org/images/logo.gif";
+          status.level = "OK";
+          status.description = "OK";
+          registration."" = ["MEMBER" "CLIENT"];
+          registration.load = "OPEN";
+          install.type = "PACKAGE";
+        };
+        software = {
+          name = "Davical";
+          website = "https://www.davical.org/";
+          license.url = "https://gitlab.com/davical-project/davical/-/blob/master/COPYING";
+          license.name = "GNU General Public License Version 2";
+          version = pkgs.webapps.davical.version;
+          source.url = "https://gitlab.com/davical-project/davical/";
+          modules = "infcloud";
+        };
+      };
+      #calendar = {
+      #  file.datetime = "2022-08-22T00:00:00";
+      #  service = {
+      #    name = "Calendar";
+      #    description = "Opensource CalDAV web client";
+      #    website = "https://dav.immae.eu/caldavzap/";
+      #    logo = "https://dav.immae.eu/caldavzap/images/infcloud_logo.svg";
+      #    status.level = "OK";
+      #    status.description = "OK";
+      #    registration."" = ["MEMBER" "CLIENT"];
+      #    registration.load = "OPEN";
+      #    install.type = "PACKAGE";
+      #  };
+      #  software = {
+      #    name = "InfCloud";
+      #    website = "https://inf-it.com/open-source/clients/infcloud/";
+      #    license.url = "https://www.gnu.org/licenses/agpl-3.0.en.html";
+      #    license.name = "GNU Affero General Public License (version 3.0)";
+      #    version = pkgs.webapps.infcloud.version;
+      #    source.url = "https://inf-it.com/open-source/clients/infcloud/";
+      #  };
+      #};
+      #contacts = {
+      #  file.datetime = "2022-08-22T00:00:00";
+      #  service = {
+      #    name = "Contacts";
+      #    description = "Opensource Carddav web client";
+      #    website = "https://dav.immae.eu/carddavmate/";
+      #    logo = "https://dav.immae.eu/caldavzap/images/infcloud_logo.svg";
+      #    status.level = "OK";
+      #    status.description = "OK";
+      #    registration."" = ["MEMBER" "CLIENT"];
+      #    registration.load = "OPEN";
+      #    install.type = "PACKAGE";
+      #  };
+      #  software = {
+      #    name = "InfCloud";
+      #    website = "https://inf-it.com/open-source/clients/infcloud/";
+      #    license.url = "https://www.gnu.org/licenses/agpl-3.0.en.html";
+      #    license.name = "GNU Affero General Public License (version 3.0)";
+      #    version = pkgs.webapps.infcloud.version;
+      #    source.url = "https://inf-it.com/open-source/clients/infcloud/";
+      #  };
+      #};
+    };
     system.activationScripts.davical = davical.activationScript;
     secrets.keys = davical.keys;
     services.websites.env.tools.modules = davical.apache.modules;