]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/cryptpad/default.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / cryptpad / default.nix
index 69b9877952575a2f8da7d0b33c925281fb658445..bea5c44f4cc37c07274eccb554672eae240a97d4 100644 (file)
@@ -32,6 +32,42 @@ in
 {
   options.myServices.websites.tools.cryptpad.enable = lib.mkEnableOption "Enable Cryptpad";
   config = lib.mkIf cfg.enable {
+    myServices.chatonsProperties.hostings.cryptpad = {
+      file.datetime = "2022-08-21T01:20:00";
+      hosting = {
+        name = "Cryptpad";
+        description = "Collaboration suite, encrypted and open-source";
+        website = "https://cryptpad.immae.eu/";
+        logo = "https://cryptpad.immae.eu/customize/favicon/main-favicon.png";
+        type = "INSTANCE";
+        status.level = "OK";
+        status.description = "OK";
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+    };
+    myServices.chatonsProperties.services.cryptpad = {
+      file.datetime = "2022-08-21T01:20:00";
+      service = {
+        name = "Cryptpad";
+        description = "Collaboration suite, encrypted and open-source";
+        website = "https://cryptpad.immae.eu/";
+        logo = "https://cryptpad.immae.eu/customize/favicon/main-favicon.png";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["NONE" "FREE" "MEMBER" "CLIENT"];
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "Cryptpad";
+        website = "https://cryptpad.org/";
+        license.url = "https://github.com/xwiki-labs/cryptpad/blob/main/LICENSE";
+        license.name = "GNU Affero General Public License v3.0";
+        version = pkgs.cryptpad.version;
+        source.url = "https://github.com/xwiki-labs/cryptpad";
+      };
+    };
     myServices.tools.cryptpad.farm.hosts.immaeEu = {
       inherit domain port;
       config = configFile;