]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/production.nix
Migrate php sessions to redis
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / production.nix
index e4e29c710d29f2ce242088e8f99ffca17dfeea04..2fb5a3231dc117fb972c9744d033213d3ccd5495 100644 (file)
 { lib, pkgs, config,  ... }:
 let
   secrets = config.myEnv.websites.piedsjaloux.production;
-  app = pkgs.webapps.piedsjaloux.override { environment = secrets.environment; };
   cfg = config.myServices.websites.piedsjaloux.production;
-  pcfg = config.services.phpApplication;
+  texlive = pkgs.texlive.combine { inherit (pkgs.texlive) attachfile preprint scheme-small; };
+  ftpRoot = "/var/lib/piedsjaloux_production";
+  phpRoot = "${ftpRoot}/php";
+  webRoot = "${phpRoot}/web";
+  varDir = "${ftpRoot}/var";
+  packagePath = "/var/lib/ftp/release.immae.eu/buildbot/Piedsjaloux";
+  branch = "master";
 in {
   options.myServices.websites.piedsjaloux.production.enable = lib.mkEnableOption "enable PiedsJaloux's website in production";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.piedsjaloux_prod.rootDir = app.varDir;
     services.webstats.sites = [ { name = "piedsjaloux.fr"; } ];
-    services.phpApplication.apps.piedsjaloux_prod = {
-      websiteEnv = "production";
-      httpdUser = config.services.httpd.Prod.user;
-      httpdGroup = config.services.httpd.Prod.group;
-      inherit (app) webRoot varDir;
-      varDirPaths = {
-        "tmp" = "0700";
+    services.phpfpm.pools.piedsjaloux_production = {
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      settings = {
+        "listen.owner" = config.services.httpd.Prod.user;
+        "listen.group" = config.services.httpd.Prod.group;
+        "php_admin_value[open_basedir]" = builtins.concatStringsSep ":" [
+          ftpRoot
+          config.secrets.fullPaths."websites/piedsjaloux/production"
+          "/tmp"
+        ];
+        "php_admin_value[session.save_handler]" = "redis";
+        "php_admin_value[session.save_path]" = "'unix:///run/redis-php-sessions/redis.sock?persistent=1&prefix=PiedsJaloux:Production:'";
+        "php_admin_value[upload_max_filesize]" = "20M";
+        "php_admin_value[post_max_size]" = "20M";
+        #"php_admin_flag[log_errors]" = "on";
+        "pm" = "dynamic";
+        "pm.max_children" = "20";
+        "pm.start_servers" = "2";
+        "pm.min_spare_servers" = "1";
+        "pm.max_spare_servers" = "3";
       };
-      inherit app;
-      serviceDeps = [ "mysql.service" ];
-      preStartActions = [
-        "./bin/console --env=${app.environment} cache:clear --no-warmup"
-      ];
-      phpOpenbasedir = [ "/tmp" ];
-      phpPool = ''
-        php_admin_value[upload_max_filesize] = 20M
-        php_admin_value[post_max_size] = 20M
-        ;php_admin_flag[log_errors] = on
-        env[PATH] = ${lib.makeBinPath [ pkgs.apg pkgs.unzip ]}
-        pm = dynamic
-        pm.max_children = 20
-        pm.start_servers = 2
-        pm.min_spare_servers = 1
-        pm.max_spare_servers = 3
-      '';
-      phpWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-piedsjaloux"
-      ];
+      phpPackage = pkgs.php74.withExtensions({ enabled, all }: enabled ++ [all.redis]);
     };
+    systemd.services."phpfpm-piedsjaloux_production" = {
+      after = lib.mkAfter ["mysql.service"];
+      wants = ["mysql.service"];
+      path = lib.mkAfter [ pkgs.gnutar pkgs.gzip pkgs.php74 ];
+      preStart = let
+        script = pkgs.writeScriptBin "piedsjaloux-production-pre" ''
+          #! ${pkgs.stdenv.shell}
+
+          [ -f ${packagePath}/${branch}.tar.gz ] || exit 1
 
-    secrets.keys = [
-      {
-        dest = "webapps/${app.environment}-piedsjaloux";
-        user = config.services.httpd.Prod.user;
-        group = config.services.httpd.Prod.group;
-        permissions = "0400";
-        text = ''
-          # This file is auto-generated during the composer install
-          parameters:
-              database_host: ${secrets.mysql.host}
-              database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.database}
-              database_user: ${secrets.mysql.user}
-              database_password: ${secrets.mysql.password}
-              database_server_version: ${pkgs.mariadb.mysqlVersion}
-              mailer_transport: smtp
-              mailer_host: 127.0.0.1
-              mailer_user: null
-              mailer_password: null
-              secret: ${secrets.secret}
-              pdflatex: "${pkgs.texlive.combine { inherit (pkgs.texlive) attachfile preprint scheme-small; }}/bin/pdflatex"
-          leapt_im:
-              binary_path: ${pkgs.imagemagick}/bin
+          cd ${ftpRoot}
+          if ! [ -f .tarball_sum ] || ! sha256sum -c .tarball_sum; then
+            tar -xf ${packagePath}/${branch}.tar.gz --one-top-level=php_new
+            if [ -d php ]; then
+              mv php php_old
+            fi
+            mv php_new php
+          fi
+          cd php
+          rm -rf var/{logs,cache,data,miniatures,tmp}
+          ln -sf ${varDir}/{logs,cache,data,miniatures,tmp} var/
+          ln -sf ${config.secrets.fullPaths."websites/piedsjaloux/production"} app/config/parameters.yml
+          ./bin/console --env=${secrets.environment} cache:clear --no-warmup
+          sha256sum ${packagePath}/${branch}.tar.gz > ${ftpRoot}/.tarball_sum
         '';
-      }
-    ];
+      in
+        "/run/wrappers/bin/sudo -u ${config.services.httpd.Prod.user} ${script}/bin/piedsjaloux-production-pre";
+      postStart = let
+        script = pkgs.writeScriptBin "piedsjaloux-production-post" ''
+          #! ${pkgs.stdenv.shell}
+
+          cd ${ftpRoot}
+          if [ -d php_old ]; then
+            rm -rf php_old
+          fi
+        '';
+      in
+        "/run/wrappers/bin/sudo -u ${config.services.httpd.Prod.user} ${script}/bin/piedsjaloux-production-post";
+      serviceConfig.TimeoutStartSec="infinity";
+    };
+    services.filesWatcher.phpfpm-piedsjaloux_production = {
+      restart = true;
+      paths = [ "${packagePath}/${branch}.tar.gz" ];
+    };
+
+    system.activationScripts.piedsjaloux_production = {
+      deps = ["users"];
+      text = ''
+        install -m 0700 -o ${config.services.httpd.Prod.user} -g ${config.services.httpd.Prod.group} -d ${ftpRoot}
+      '';
+    };
+
+    secrets.keys."websites/piedsjaloux/production" = {
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      permissions = "0400";
+      text = ''
+        # This file is auto-generated during the composer install
+        parameters:
+            database_host: ${secrets.mysql.host}
+            database_port: ${secrets.mysql.port}
+            database_name: ${secrets.mysql.database}
+            database_user: ${secrets.mysql.user}
+            database_password: ${secrets.mysql.password}
+            database_server_version: ${config.myServices.databases.mariadb.package.mysqlVersion}
+            mailer_transport: smtp
+            mailer_host: 127.0.0.1
+            mailer_user: null
+            mailer_password: null
+            secret: ${secrets.secret}
+            pdflatex: "${texlive}/bin/pdflatex"
+        leapt_im:
+            binary_path: ${pkgs.imagemagick}/bin
+      '';
+    };
 
-    services.websites.env.production.vhostConfs.piedsjaloux_prod = {
+    services.websites.env.production.vhostConfs.piedsjaloux_production = {
       certName     = "piedsjaloux";
       certMainHost = "piedsjaloux.fr";
       hosts        = [ "piedsjaloux.fr" "www.piedsjaloux.fr" ];
-      root         = pcfg.webappDirs.piedsjaloux_prod;
+      root         = webRoot;
       extraConfig  = [
         ''
         RewriteEngine on
@@ -79,12 +126,12 @@ in {
         RewriteRule ^(.+)$ https://www.piedsjaloux.fr$1 [R=302,L]
 
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.piedsjaloux_prod}|fcgi://localhost"
+          SetHandler "proxy:unix:${config.services.phpfpm.pools.piedsjaloux_production.socket}|fcgi://localhost"
         </FilesMatch>
 
         Use Stats piedsjaloux.fr
 
-        <Directory ${pcfg.webappDirs.piedsjaloux_prod}>
+        <Directory ${webRoot}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted