]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/nath/villon.nix
Change Nath’s name
[perso/Immae/Config/Nix.git] / modules / private / websites / nath / villon.nix
diff --git a/modules/private/websites/nath/villon.nix b/modules/private/websites/nath/villon.nix
new file mode 100644 (file)
index 0000000..57a1df5
--- /dev/null
@@ -0,0 +1,42 @@
+{ lib, pkgs, config,  ... }:
+let
+  cfg = config.myServices.websites.nath.villon;
+  varDir = "/var/lib/ftp/nath";
+  env = config.myEnv.websites.nath;
+  domain = "sntvillon.immae.eu";
+  apacheUser = config.services.httpd.Prod.user;
+  apacheGroup = config.services.httpd.Prod.group;
+in {
+  options.myServices.websites.nath.villon.enable = lib.mkEnableOption "enable Nath's website";
+
+  config = lib.mkIf cfg.enable {
+    services.webstats.sites = [ { name = domain; } ];
+
+    system.activationScripts.nath_villon = {
+      deps = [ "users" ];
+      text = ''
+        install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${varDir}
+      '';
+    };
+    security.acme.certs."ftp".extraDomains."${domain}" = null;
+
+    services.websites.env.production.vhostConfs.nath_villon = {
+      certName     = "nath";
+      certMainHost = domain;
+      hosts        = [ domain ];
+      root         = varDir;
+      extraConfig  = [
+        ''
+        Use Stats ${domain}
+
+        <Directory ${varDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride None
+          Require all granted
+        </Directory>
+          ''
+      ];
+    };
+  };
+}