]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/leila/production.nix
Fix php-fpm that were on-demand instead of dynamic
[perso/Immae/Config/Nix.git] / modules / private / websites / leila / production.nix
index 8385bc7f081807e8bc4693983f32ee4986cad207..96ba8cb307195a40fa028f1e674ac7fd545441cc 100644 (file)
@@ -15,9 +15,11 @@ in {
         "listen.owner" = apacheUser;
         "listen.group" = apacheGroup;
 
-        "pm" = "ondemand";
-        "pm.max_children" = "5";
-        "pm.process_idle_timeout" = "60";
+        "pm" = "dynamic";
+        "pm.max_children" = "20";
+        "pm.start_servers" = "2";
+        "pm.min_spare_servers" = "1";
+        "pm.max_spare_servers" = "3";
 
         "php_admin_value[open_basedir]" = "${varDir}:/tmp";
         "php_admin_value[max_execution_time]" = "1800";