]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/leila/production.nix
Remove overlay that overrides the php version
[perso/Immae/Config/Nix.git] / modules / private / websites / leila / production.nix
index 4390d592d7e99039bc70ccaf45eba24c6183ef08..4fcc2d3668dd936065b88df06d91b6c6e3f8d91d 100644 (file)
@@ -2,23 +2,27 @@
 let
   cfg = config.myServices.websites.leila.production;
   varDir = "/var/lib/ftp/leila";
+  apacheUser = config.services.httpd.Prod.user;
+  apacheGroup = config.services.httpd.Prod.group;
 in {
   options.myServices.websites.leila.production.enable = lib.mkEnableOption "enable Leila's websites in production";
 
   config = lib.mkIf cfg.enable {
-    services.phpfpm.poolConfigs.leila = ''
-      listen = /run/phpfpm/leila.sock
-      user = wwwrun
-      group = wwwrun
-      listen.owner = wwwrun
-      listen.group = wwwrun
+    services.phpfpm.pools.leila = {
+      user = apacheUser;
+      group = apacheGroup;
+      settings = {
+        "listen.owner" = apacheUser;
+        "listen.group" = apacheGroup;
 
-      pm = ondemand
-      pm.max_children = 5
-      pm.process_idle_timeout = 60
+        "pm" = "ondemand";
+        "pm.max_children" = "5";
+        "pm.process_idle_timeout" = "60";
 
-      php_admin_value[open_basedir] = "${varDir}:/tmp"
-      '';
+        "php_admin_value[open_basedir]" = "${varDir}:/tmp";
+      };
+      phpPackage = pkgs.php72;
+    };
 
     services.webstats.sites = [
       { name = "leila.bouya.org"; }
@@ -44,7 +48,7 @@ in {
           Require ldap-group cn=chorale.leila.bouya.org,cn=httpd,ou=services,dc=immae,dc=eu
 
           <FilesMatch "\.php$">
-            SetHandler "proxy:unix:/run/phpfpm/leila.sock|fcgi://localhost"
+            SetHandler "proxy:unix:${config.services.phpfpm.pools.leila.socket}|fcgi://localhost"
           </FilesMatch>
         </Directory>
           ''
@@ -64,7 +68,7 @@ in {
           AllowOverride None
 
           <FilesMatch "\.php$">
-            SetHandler "proxy:unix:/run/phpfpm/leila.sock|fcgi://localhost"
+            SetHandler "proxy:unix:${config.services.phpfpm.pools.leila.socket}|fcgi://localhost"
           </FilesMatch>
         </Directory>
           ''
@@ -87,7 +91,7 @@ in {
           Require ldap-group cn=chorale.leila.bouya.org,cn=httpd,ou=services,dc=immae,dc=eu
 
           <FilesMatch "\.php$">
-            SetHandler "proxy:unix:/run/phpfpm/leila.sock|fcgi://localhost"
+            SetHandler "proxy:unix:${config.services.phpfpm.pools.leila.socket}|fcgi://localhost"
           </FilesMatch>
         </Directory>
         <Directory ${varDir}>