]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/isabelle/aten_integration.nix
Rework integration websites
[perso/Immae/Config/Nix.git] / modules / private / websites / isabelle / aten_integration.nix
index c55ef929b202683fc7a660632ba2f6191e3024d8..21ed00f50066c6d0dbceb65c796a8494d35177c5 100644 (file)
@@ -1,29 +1,30 @@
 { lib, pkgs, config,  ... }:
 let
   secrets = config.myEnv.websites.isabelle.aten_integration;
-  webRoot = "/var/lib/ftp/immae/aten/public";
   cfg = config.myServices.websites.isabelle.aten_integration;
-  pcfg = config.services.phpApplication;
+  ftpRoot = "/var/lib/isabelle_aten_integration";
+  phpRoot = "${ftpRoot}/php";
+  webRoot = "${phpRoot}/public";
+  varDir = "${ftpRoot}/var";
+  sessionDir = "${ftpRoot}/sessions";
+  packagePath = "/var/lib/ftp/release.immae.eu/buildbot/IsabelleAten";
+  branch = "test";
 in {
   options.myServices.websites.isabelle.aten_integration.enable = lib.mkEnableOption "enable Aten's website in integration";
 
   config = lib.mkIf cfg.enable {
-    services.phpApplication.apps.isabelle_aten_integration = {
-      websiteEnv = "integration";
-      httpdUser = config.services.httpd.Inte.user;
-      httpdGroup = config.services.httpd.Inte.group;
-      httpdWatchFiles = [
-        config.secrets.fullPaths."websites/isabelle/aten_integration"
-      ];
-      inherit webRoot;
-      varDir = "/var/lib/ftp/immae/aten_var";
-      app = "/var/lib/ftp/immae/aten";
-      serviceDeps = [ "postgresql.service" ];
-      preStartActions = [
-        "APP_ENV=dev ./bin/console --env=dev cache:clear --no-warmup"
-      ];
-      phpOpenbasedir = [ "/tmp" ];
-      phpPool = {
+    services.phpfpm.pools.isabelle_aten_integration = {
+      user = config.services.httpd.Inte.user;
+      group = config.services.httpd.Inte.group;
+      settings = {
+        "listen.owner" = config.services.httpd.Inte.user;
+        "listen.group" = config.services.httpd.Inte.group;
+        "php_admin_value[open_basedir]" = builtins.concatStringsSep ":" [
+          ftpRoot
+          config.secrets.fullPaths."websites/isabelle/aten_integration"
+          "/tmp"
+        ];
+        "php_admin_value[session.save_path]" = sessionDir;
         "php_admin_value[upload_max_filesize]" = "20M";
         "php_admin_value[post_max_size]" = "20M";
         #"php_admin_flag[log_errors]" = "on";
@@ -36,6 +37,56 @@ in {
       };
       phpPackage = pkgs.php72;
     };
+    systemd.services."phpfpm-isabelle_aten_integration" = {
+      after = lib.mkAfter ["postgresql.service"];
+      wants = ["postgresql.service"];
+      path = lib.mkAfter [ pkgs.gnutar pkgs.gzip pkgs.php72 ];
+      preStart = let
+        script = pkgs.writeScriptBin "isabelle-aten-integration" ''
+          #! ${pkgs.stdenv.shell}
+
+          [ -f ${packagePath}/${branch}.tar.gz ] || exit 1
+
+          cd ${ftpRoot}
+          if ! [ -f .tarball_sum ] || ! sha256sum -c .tarball_sum; then
+            tar -xf ${packagePath}/${branch}.tar.gz --one-top-level=php_new
+            if [ -d php ]; then
+              mv php php_old
+            fi
+            mv php_new php
+          fi
+          cd php
+          rm -rf var/{log,cache}
+          ln -sf ${varDir}/{log,cache} var/
+          SYMFONY_ENV=dev APP_ENV=dev ./bin/console --env=dev cache:clear --no-warmup
+          sha256sum ${packagePath}/${branch}.tar.gz > ${ftpRoot}/.tarball_sum
+        '';
+      in
+        "/run/wrappers/bin/sudo -u ${config.services.httpd.Inte.user} ${script}/bin/isabelle-aten-integration";
+      postStart = let
+        script = pkgs.writeScriptBin "isabelle-aten-integration-post" ''
+          #! ${pkgs.stdenv.shell}
+
+          cd ${ftpRoot}
+          if [ -d php_old ]; then
+            rm -rf php_old
+          fi
+        '';
+      in
+        "/run/wrappers/bin/sudo -u ${config.services.httpd.Inte.user} ${script}/bin/isabelle-aten-integration-post";
+      serviceConfig.TimeoutStartSec="infinity";
+    };
+    services.filesWatcher.phpfpm-isabelle_aten_integration = {
+      restart = true;
+      paths = [ "${packagePath}/${branch}.tar.gz" ];
+    };
+
+    system.activationScripts.isabelle_aten_integration = {
+      deps = ["users"];
+      text = ''
+        install -m 0700 -o ${config.services.httpd.Inte.user} -g ${config.services.httpd.Inte.group} -d ${ftpRoot} ${sessionDir}
+      '';
+    };
 
     secrets.keys."websites/isabelle/aten_integration" = {
       user = config.services.httpd.Inte.user;
@@ -47,7 +98,7 @@ in {
         #   vendor/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php#parseDatabaseUrlQuery
         psql_url = with secrets.postgresql; "pdo-pgsql://${user}:${password}@invalid:${port}/${database}?host=${socket}";
       in ''
-        SetEnv APP_ENV      "dev"
+        SetEnv APP_ENV      "${secrets.environment}"
         SetEnv APP_SECRET   "${secrets.secret}"
         SetEnv DATABASE_URL "${psql_url}"
         '';
@@ -60,7 +111,7 @@ in {
       extraConfig = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.isabelle_aten_integration}|fcgi://localhost"
+          SetHandler "proxy:unix:${config.services.phpfpm.pools.isabelle_aten_integration.socket}|fcgi://localhost"
         </FilesMatch>
 
         Include ${config.secrets.fullPaths."websites/isabelle/aten_integration"}