]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/temp.nix
Remove attachment header for temp.immae.eu
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / temp.nix
index 0b2a3a3ed56f4210321f492c7d74642b2abaa264..899bb3a5e00046e4815f5dcee103fce113b5b144 100644 (file)
@@ -1,14 +1,14 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   cfg = config.myServices.websites.immae.temp;
   varDir = "/var/lib/ftp/temp.immae.eu";
-  env = myconfig.env.websites.temp;
+  env = config.myEnv.websites.temp;
 in {
   options.myServices.websites.immae.temp.enable = lib.mkEnableOption "enable Temp' website";
 
   config = lib.mkIf cfg.enable {
-    services.websites.production.modules = [ "headers" ];
-    services.websites.production.vhostConfs.temp = {
+    services.websites.env.production.modules = [ "headers" ];
+    services.websites.env.production.vhostConfs.temp = {
       certName    = "eldiron";
       addToCerts  = true;
       hosts       = [ "temp.immae.eu" ];
@@ -16,9 +16,6 @@ in {
       extraConfig = [
         ''
         Use Apaxy "${varDir}" "title .duplicity-ignore"
-        <FilesMatch ".+">
-          Header set Content-Disposition attachment
-        </FilesMatch>
         <Directory "${varDir}">
           Options -Indexes
           AllowOverride None