]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add recettes website
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index 87bb848d7ddd044e578469158fa56890baa34b66..dff105363b77923fe215fef58160af7f7793066c 100644 (file)
@@ -4,6 +4,7 @@ let
   varDir = "/var/lib/buildbot/outputs/immaeEu";
   coursDir = "/var/lib/buildbot/outputs/cours";
   rechercheDir = "/var/lib/buildbot/outputs/recherche";
+  recettesDir = "/var/lib/buildbot/outputs/recettes";
   env = config.myEnv.websites.immae;
 in {
   options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
@@ -14,12 +15,25 @@ in {
     services.websites.env.production.vhostConfs.immae = {
       certName    = "eldiron";
       addToCerts  = true;
-      hosts       = [ "www.immae.eu" ];
+      hosts       = [ "www.immae.eu" "immae.eu" ];
       root        = varDir;
       extraConfig = [
         ''
         Use Stats www.immae.eu
 
+        <LocationMatch /.well-known/(webfinger|host-meta)>
+          Header always set Referrer-Policy "strict-origin-when-cross-origin"
+          Header always set Strict-Transport-Security "max-age=31536000"
+          RequestHeader set X-Forwarded-Proto "https"
+
+          RewriteRule ^(.*)$ https://mastodon.immae.eu%{REQUEST_URI} [QSA,L]
+        </LocationMatch>
+
+        RewriteEngine On
+        RewriteCond "%{REQUEST_URI}" "!^/.well-known/(webfinger|host-meta)"
+        RewriteCond "%{HTTP_HOST}" "!^www\.immae\.eu$" [NC]
+        RewriteRule ^(.+)$ https://www.immae.eu$1 [R=302,L]
+
         <Directory ${varDir}>
           DirectoryIndex index.htm index.html
           Options Indexes FollowSymLinks MultiViews Includes
@@ -42,6 +56,14 @@ in {
           AllowOverride All
           Require all granted
         </Directory>
+
+        Alias /recettes ${recettesDir}
+        <Directory ${recettesDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
         ''
       ];
     };