]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Use local website for research
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index c63839e6cc43347eb42302af47e7ebf807f95522..439b455171f3b9bae2bdb95fc21306e8f52943f4 100644 (file)
@@ -58,6 +58,14 @@ in {
           Require all granted
         </Directory>
 
+        Alias /eurl ${./eurl}
+        <Directory ${./eurl}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride None
+          Require all granted
+        </Directory>
+
         Alias /recherche ${rechercheDir}
         <Directory ${rechercheDir}>
           DirectoryIndex index.htm index.html
@@ -98,9 +106,14 @@ in {
       certName    = "immae";
       addToCerts  = true;
       hosts       = [ "bouya.org" "www.bouya.org" ];
-      root        = null;
+      root        = rechercheDir;
       extraConfig = [ ''
-        RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://www.normalesup.org/~bouya/
+        <Directory ${rechercheDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
         '' ];
     };
   };