]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/production.nix
Add jardin site
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
index 95a8a41a8f174b008b531b986ae0483d78f6320b..3d5f49ec5928ee65fd897e4883adb8a581f74855 100644 (file)
@@ -5,6 +5,7 @@ let
   coursDir = "/var/lib/buildbot/outputs/immae/cours";
   rechercheDir = "/var/lib/buildbot/outputs/immae/recherche";
   recettesDir = "/var/lib/buildbot/outputs/immae/recettes";
+  jardinDir = "/var/lib/buildbot/outputs/immae/jardin";
   historyDir = "/var/lib/buildbot/outputs/immae/history";
   docsDir = "/var/lib/buildbot/outputs/immae/docs/";
   env = config.myEnv.websites.immae;
@@ -94,6 +95,14 @@ in {
           Require all granted
         </Directory>
 
+        Alias /jardin ${jardinDir}
+        <Directory ${jardinDir}>
+          DirectoryIndex index.htm index.html
+          Options Indexes FollowSymLinks MultiViews Includes
+          AllowOverride All
+          Require all granted
+        </Directory>
+
         Alias /history ${historyDir}
         <Directory ${historyDir}>
           DirectoryIndex index.html