]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/immae/history/default.nix
Add history page
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / history / default.nix
diff --git a/modules/private/websites/immae/history/default.nix b/modules/private/websites/immae/history/default.nix
new file mode 100644 (file)
index 0000000..2335627
--- /dev/null
@@ -0,0 +1,27 @@
+{ lib, bundlerEnv, ruby, stdenv }:
+
+# rebuild with bundix -l
+let
+  jekyll = bundlerEnv rec {
+    name = pname + "-" + version;
+    pname = "jekyll";
+    version = (import ./gemset.nix).jekyll.version;
+
+    inherit ruby;
+    gemdir = ./.;
+  };
+in
+  stdenv.mkDerivation rec {
+    pname = "changelog";
+    version = "1";
+    src = ./.;
+    buildInputs = [ jekyll ];
+    phases = [ "unpackPhase" "buildPhase" "installPhase"];
+    buildPhase = ''
+      jekyll build
+    '';
+
+    installPhase = ''
+      cp -a _site $out
+    '';
+  }