]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/denise/oms.nix
Write peertube flake
[perso/Immae/Config/Nix.git] / modules / private / websites / denise / oms.nix
index 965046891868ea275c30138af9164b30f379d70f..2c5e90e3b33e88fa6d86394942ae2a081c7260c0 100644 (file)
@@ -1,7 +1,7 @@
 { lib, config, pkgs, ... }:
 let
   cfg = config.myServices.websites.denise.oms;
-  varDir = "/var/lib/buildbot/outputs/denise_oms";
+  varDir = "/var/lib/buildbot/outputs/denise/oms";
   socket = "/run/denise_oms/socket.sock";
 in {
   options.myServices.websites.denise.oms.enable = lib.mkEnableOption "enable Denise's OMS website";
@@ -33,7 +33,7 @@ in {
         Type = "simple";
         WorkingDirectory = varDir;
         ExecStart = let
-          python = pkgs.python3.withPackages (p: [ p.gunicorn p.flask p.matplotlib ]);
+          python = pkgs.python3.withPackages (p: [ p.gunicorn p.flask p.matplotlib p.unidecode ]);
         in
           "${python}/bin/gunicorn -w4 -p /run/denise_oms/gunicorn.pid --bind unix:${socket} app:app";
         User = "buildbot";