]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/denise/aventuriers.nix
Add Denise aventurier website
[perso/Immae/Config/Nix.git] / modules / private / websites / denise / aventuriers.nix
diff --git a/modules/private/websites/denise/aventuriers.nix b/modules/private/websites/denise/aventuriers.nix
new file mode 100644 (file)
index 0000000..33df53e
--- /dev/null
@@ -0,0 +1,26 @@
+{ lib, config, pkgs, ... }:
+let
+  cfg = config.myServices.websites.denise.aventuriers;
+  varDir = "/var/lib/buildbot/outputs/denise/aventuriers";
+in {
+  options.myServices.websites.denise.aventuriers.enable = lib.mkEnableOption "enable Denise's Aventuriers website";
+
+  config = lib.mkIf cfg.enable {
+    services.websites.env.production.vhostConfs.denise_aventuriers = {
+      certName     = "denise";
+      addToCerts   = true;
+      hosts        = [ "aventuriers.syanni.eu" ];
+      root         = varDir;
+      extraConfig  = [
+        ''
+          <Directory ${varDir}>
+            DirectoryIndex index.html
+            Options Indexes FollowSymLinks MultiViews Includes
+            AllowOverride None
+            Require all granted
+          </Directory>
+          ''
+      ];
+    };
+  };
+}