]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Upgrade odoo to 14
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index 07ffc3e98fb431186150868512488733c5cded6e..701ad1df7a2f7dcfca6283ad6f5f72c6d88df58b 100644 (file)
@@ -1,7 +1,7 @@
 { lib, pkgs, config, ... }:
 let
-  www_root = "/run/current-system/webapps/_www";
-  theme_root = "/run/current-system/webapps/_theme";
+  www_root = ./_www;
+  theme_root = pkgs.webapps.apache-theme.theme;
   apacheConfig = {
     cache = {
       # This setting permits to ignore time-based cache for files in the
@@ -52,7 +52,7 @@ let
           LDAPOpCacheTTL 600
         </IfModule>
 
-        Include /var/secrets/apache-ldap
+        Include ${config.secrets.fullPaths."apache-ldap"}
       '';
     };
     global = {
@@ -102,15 +102,10 @@ in
   options.myServices.websites.enable = lib.mkEnableOption "enable websites";
 
   config = lib.mkIf config.myServices.websites.enable {
-    services.duplyBackup.profiles.php = {
-      rootDir = "/var/lib/php";
-      remotes = [ "eriomem" "ovh" ];
-    };
     users.users.wwwrun.extraGroups = [ "keys" ];
     networking.firewall.allowedTCPPorts = [ 80 443 ];
 
-    secrets.keys = [{
-      dest = "apache-ldap";
+    secrets.keys."apache-ldap" = {
       user = "wwwrun";
       group = "wwwrun";
       permissions = "0400";
@@ -126,7 +121,7 @@ in
           </IfModule>
         </Macro>
         '';
-    }];
+    };
 
     system.activationScripts = {
       httpd = ''
@@ -149,9 +144,9 @@ in
       };
     };
 
-    services.filesWatcher.httpdProd.paths = [ "/var/secrets/apache-ldap" ];
-    services.filesWatcher.httpdInte.paths = [ "/var/secrets/apache-ldap" ];
-    services.filesWatcher.httpdTools.paths = [ "/var/secrets/apache-ldap" ];
+    services.filesWatcher.httpdProd.paths = [ config.secrets.fullPaths."apache-ldap" ];
+    services.filesWatcher.httpdInte.paths = [ config.secrets.fullPaths."apache-ldap" ];
+    services.filesWatcher.httpdTools.paths = [ config.secrets.fullPaths."apache-ldap" ];
 
     services.websites.env.production = {
       enable = true;
@@ -217,10 +212,6 @@ in
       };
     };
 
-    services.websites.webappDirs = {
-      _www = ./_www;
-      _theme = pkgs.webapps.apache-theme.theme;
-    };
     myServices.websites = {
       bakeer.cloud.enable = true;
       capitaines.landing_pages.enable = true;
@@ -230,6 +221,12 @@ in
         production.enable = true;
       };
 
+      christophe_carpentier = {
+        website.enable = true;
+        agorakit.enable = true;
+        agora-project.enable = true;
+      };
+
       cip-ca = {
         sympa.enable = true;
       };
@@ -243,11 +240,15 @@ in
         evariste.enable = true;
         denisejerome.enable = true;
         oms.enable = true;
+        bingo.enable = true;
         aventuriers.enable = true;
         production.enable = true;
       };
 
-      emilia.moodle.enable = false;
+      emilia = {
+        moodle.enable = false;
+        atelierfringant.enable = true;
+      };
 
       florian = {
         app.enable = true;
@@ -280,12 +281,20 @@ in
 
       nath.villon.enable = true;
 
+      nicecoop = {
+        gestion-compte.enable = true;
+        gestion-compte-integration.enable = true;
+        odoo.enable = true;
+      };
       papa = {
         surveillance.enable = true;
         maison_bbc.enable = true;
       };
 
-      patrick_fodella.production.enable = true;
+      patrick_fodella = {
+        ecolyeu.enable = true;
+        altermondia.enable = true;
+      };
 
       piedsjaloux = {
         integration.enable = true;
@@ -317,6 +326,8 @@ in
       tools.performance.enable = true;
       tools.tools.enable = true;
       tools.email.enable = true;
+      tools.stats.enable = false;
+      tools.visio.enable = true;
 
       games.codenames.enable = true;
       games.terraforming-mars.enable = true;