]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Finish removal of php-application module
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index b007a6e22696cb1d9bbd0e43994e898074e1c5dc..47a41ab8847a2eda79ae1b3327b0f1a36e13ee9f 100644 (file)
@@ -1,7 +1,7 @@
 { lib, pkgs, config, ... }:
 let
   www_root = ./_www;
-  theme_root = pkgs.webapps.apache-theme.theme;
+  theme_root = (pkgs.webapps.apache-theme {}).theme;
   apacheConfig = {
     cache = {
       # This setting permits to ignore time-based cache for files in the
@@ -73,7 +73,7 @@ let
       '';
     };
     apaxy = {
-      extraConfig = (pkgs.webapps.apache-theme.override { inherit theme_root; }).apacheConfig;
+      extraConfig = (pkgs.webapps.apache-theme { inherit theme_root; }).apacheConfig;
     };
     http2 = {
       modules = [ "http2" ];
@@ -102,6 +102,27 @@ in
   options.myServices.websites.enable = lib.mkEnableOption "enable websites";
 
   config = lib.mkIf config.myServices.websites.enable {
+    myServices.chatonsProperties.hostings.web = {
+      file.datetime = "2022-08-22T01:30:00";
+      hosting = {
+        name = "Hébergement Web";
+        description = "Service d'hébergement web avec php/mysql/postgresql";
+        website = "https://www.immae.eu";
+        status.level = "OK";
+        status.description = "OK";
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "Apache Httpd";
+        website = "https://httpd.apache.org/";
+        license.url = "https://www.apache.org/licenses/";
+        license.name = "Apache License Version 2";
+        version = pkgs.apacheHttpd.version;
+        source.url = "https://httpd.apache.org/download.cgi";
+        modules = "openssh,pure-ftpd";
+      };
+    };
     users.users.wwwrun.extraGroups = [ "keys" ];
     networking.firewall.allowedTCPPorts = [ 80 443 ];
 
@@ -251,7 +272,7 @@ in
 
       emilia = {
         moodle.enable = false;
-        atelierfringant.enable = true;
+        atelierfringant.enable = false;
       };
 
       florian = {
@@ -264,6 +285,7 @@ in
         production.enable = true;
         release.enable = true;
         temp.enable = true;
+        dolibarr.enable = true;
       };
 
       isabelle = {
@@ -294,6 +316,7 @@ in
         gestion-compte.enable = true;
         gestion-compte-integration.enable = true;
         odoo.enable = true;
+        dolibarrDev.enable = true;
         copanier.enable = true;
       };
 
@@ -307,7 +330,7 @@ in
       };
 
       patrick_fodella = {
-        ecolyeu.enable = true;
+        ecolyeu.enable = false;
         altermondia.enable = true;
       };